I am trying to find good names for a part of my software which I would describe as a layer
. Multiple layers can lay ontop of each other and interact only with the layer above
and the layer below
.
Each layer can either send
or receive
from either above
or below
creating 4 function which I need to name.
With respect to the sending part, a simple name is short and easy send_up
and send_down
. However for the receive, the most natural word to pick seems to be receive_from_down
and receive_from_up
. However I don't like the 2 vs 3 word solution.
I am looking for a single word to represent receive from
which makes sense in this context.
--- Edit ---
To increase clarity (Andrew Leach's comment), the reason I don't like "get" is because it's active while as "receive from" is passive. An example; if the layers are:
A
B
Assume that A
is generating data from thin air. A
would call send_down()
which is an alias to receive_from_up()
on B
. B
at a later date would call send_up()
which is an alias to receive_from_down()
on A
. At no point would a layer call it's own receive_from_down()
. So receive
half of the problem is always initiated by a neighbor. This makes me feel that get
is confusing.
To Jim: There is a hierarchy. Any layer can choose to pass a received message to the next neighbor or not. Any layer can also generate a message in either direction spontaneously.
No comments:
Post a Comment